Tuesday, May 14, 2013

MS CRM 2011 E-mail Router Configuration Manager fails to Load data

The problem i got when i install CRM 2011 E-mail router and configure it , i can not Load Data from the server, i got error:

"The E-mail router configuration manager was unable to retrieve user and queue information from the Microsoft Dynamics CRM server. This may indicate that the Microsoft Dynamics CRM server is busy. Verify that URL http://<server name:port>/<orgname> is correct. Additionaly, this problem can occur if specified access credentials are insufficient. To try again click Load Data. (The caller was not authenticated by the service.)". below is the message...

i have followed the below URLs, still did not help me...
http://social.microsoft.com/Forums/en-US/crmdeployment/thread/6ae70ca3-49a1-4f6d-a962-9fb8aa10120a
http://support.microsoft.com/kb/2394264

while troubling shooting, i found some wierd things.
in the same if i use different organization, its able to fetch and the same was also fetching.
suddenly it stopped fetching.
so i suspect there is something to the organization itself.
even i restored the affected org to different name and tried to configured, still same issue.

then i tried to disable all users except the crm admin, then its loaded happily.
then i keep enabling the users bathc wise, and found one user is causing problem.
if that user is disabled then its loading happily.
in that user i saw, the incoming profile for email was email router and out going also.
i just change the incoming to outlook and enabled the user. now it loaded.
BTW the user was just a test user.
so prefered to disable that and let the things go happily.

hope this finding will help some one.

Regards,
yes.sudhanshu

2 comments: